Showtime

秋思工作室

专注于初中教育教学管理及初中数学教学。

导航

当前位置:首页博客技巧 > 正文页面

Z-BlogPHP升级遇到的问题记录

2020年11月3日 本文作者:秋思 浏览:

  今天继续折腾我那个用Z-BlogPHP搭建的博客,课余时间几乎都耗在这上面了。但是到目前为止,虽然那博客在运转了,但还有些问题没有解决,现记录如下,待以后有时间的时候逐一解决。友情提醒:使用Z-BlogPHP必须要有好的服务器。

Z-BlogPHP升级遇到的问题记录

  一、Z-BlogPHP后台应用中心商户端无法登录账号

  那个Z-BlogPHP博客是2018年5月10日搭建的,当时的版本是Z-BlogPHP 1.5 Zero版本,应用中心客户端是2.3版本,之后因为种种原因被荒废了两年多,直到上周才开始恢复管理。登录后台时显示系统升级和应用更新提示,结果提示应用中心客户端需要先升级到V2.56版本才能登录应用商城账号。幸好这玩意可以直接升级,不然直接无法更新系统和应用了。然而,升级完成后,还是无法登录账号,页面提示如下图所示。

Z-BlogPHP应用中心客户端账户登录令牌错误提示

  目前暂时已测试解决办法:同时升级应用中心客户端版本和Z-BlogPHP版本暂时能解决这个问题。

  二、Call to undefined function curl_init()

  这个是我把原来那个Z-BlogPHP博客推倒重来时,上传本地备份的主题并启用时产生的问题,无数次搜索Z-Blog论坛和百度都没有详细解说和有效的解决办法。直到晚上看到李洋这篇文章中提到有可能是主题函数问题,刚刚又在脚本之家这篇文章中看到有可能是服务器PHP设置的问题。对比自己在本地使用PHPstudy搭建的Z-BlogPHP博客分析,基本上可以肯定是服务器PHP配置问题,需要服务器提供技术支持。相关截图如下所示。

Call to undefined function curl_init() 

  三、gzinflate() has been disabled for security reasons

  这个问题也是在安装主题、插件并启用的过程中产生的,原因有两个方面的:(1)服务器开启了PHP安全模式,导致某些函数无法使用;(2)主题或插件本身的函数有问题。实测如果是服务器的问题,可以通过切换PHP版本到7.0及以上可以解决。但是我在使用Z-BlogPHP 1.6 Valyria版本重新搭建博客时,把服务器切换PHP 7.0版本时这个问题还在,想来应该是有插件函数有问题(Z-BlogPHP 1.5 Zero版本安装后只有5个插件,貌似没有这个问题出现,但Z-BlogPHP 1.6 Valyria版本安装后有一堆插件,这个办法并没有什么用。)问题截图如下所示。

gzinflate() has been disabled for security reasons

  四、应用更新超级缓慢,甚至不能完成

  以前用Z-BlogASP 1.8版本搭建博客时,直接在线安装更新插件或主题时,基本上是秒速,但目前Z-BlogPHP通过后台在线更新插件或主题完全是龟速。据传言,这跟Z-Blog官方服务器经常抽风有关系,好吧,我投降了。

  在经过无数次失败后,最张决定暂时还是使用Z-BlogPHP 1.5 Zero版本搭建,并尽量注意做到不手贱,不升级、不更新,将就着用。最后总结一句:升级有风险,重建需谨慎,没事少折腾!

版权声明:未加注说明的文章均为本站原创首发,转载本站文章请遵循署名-非商业用途-保持一致的原则

文章标签:博客  Z-Blog  ZBlogPHP  

首发网站:秋思工作室

原文链接:http://www.qiusi.me/post/127.html

欢迎在此发表评论,但请勿发垃圾广告评论或者违反国家法律或政策的言论,谢谢合作!

欢迎参与讨论,请在这里发表您的看法、交流您的观点。

最新文章

文章存档

标签

©2017-2020 秋思工作室. All rights reserved. Powered by Z-Blog. Theme named Yahei and made free by Qiusi.

本作品采用知识共享署名-非商业性使用-相同方式共享 2.5 中国大陆许可协议进行许可.